Issue
The .NET Framework agent fails to start either during installation or when the service is started automatically by Windows or manually using the Start Menu entry or the Services Manager.
If starting from the Services Manager or if the timeout occurs during installation you will see the following dialog:
When the service start is attempted by Windows or via the Agent Tray or Start menu item, the Windows System Event Log will be seen to contain an error stating:
A timeout was reached (30000 milliseconds) while waiting for the Contrast.NET Main Service to connect
Cause
It is possible that environmental considerations may cause the Agent Service to fail to complete its startup procedure within the default startup time (30 seconds) allocated by Windows. Common culprits are Anti-Virus or Malware software which may pause the startup while analysis is being performed on the service.
Resolution
The timeout in question can be changed by editing the Windows Registry manually as follows:
- Click Start, click Run, type regedit, and then click OK.
- Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
- In the right pane, locate the ServicesPipeTimeout entry.
Note If the ServicesPipeTimeout entry does not exist, you must create it. To do this, follow these steps:- On the Edit menu, point to New, and then click DWORD Value.
- Type ServicesPipeTimeout, and then press ENTER.
- Right-click ServicesPipeTimeout, and then click Modify.
- Click Decimal, type 60000, and then click OK. This value represents the time in milliseconds before a service times out.
- Restart the computer
Alternatively, using a text editor, create a file with the extension .reg
containing the following:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"ServicesPipeTimeout"=dword:0000ea60
Save the file and double-click it. You will be presented with a warning asking whether to change the registry - select Yes
, then restart the computer to pick up the change.