Issue
There are a number of common error messages that suggest a connectivity issue between the Node agent and the Contrast server:
- Unable to register server <your server name> with TeamServer. Contrast will not report findings.
- Contrast was unable to connect to TeamServer. Continuing without instrumentation.
- Error: This application is unwanted by TeamServer and no findings will be reported. Make sure the application is unarchived.
Cause
[1] Unable to register server <your server name> with TeamServer. Contrast will not report findings.
The most likely cause is incorrect credentials
[2] Contrast was unable to connect to TeamServer. Continuing without instrumentation.
This occurs if the agent couldn't communicate with the Contrast application at all.
[3] Error: This application is unwanted by TeamServer and no findings will be reported. Make sure the application is unarchived.
As is evident from the warning message, this typically occurs when the application you're using has been archived in the Contrast UI.
Resolution
[1] Unable to register server <your server name> with TeamServer. Contrast will not report findings.
Check the credentials in contrast_security.yaml. If you're sure the credentials are correct, contact your account administrator and ensure that your account has the correct permissions.
[2] Contrast was unable to connect to TeamServer. Continuing without instrumentation.
Check to make sure that the api.url
field in contrast_security.yaml is correct. It should be in the format https://app.contrastsecurity.com
. There is no need to specify the /Contrast/ route.
Sometimes it's necessary to proxy all communication between the agent and the Contrast application. To do this, run the agent with CONTRAST__API__PROXY__ENABLE=true
and CONTRAST__API__PROXY__URL=<proxy_url>
(or use the equivalent configuration settings in contrast_security.yaml). Any communication to Contrast will be sent via the proxy server specified in the URL.
[3] Error: This application is unwanted by TeamServer and no findings will be reported. Make sure the application is unarchived.
If the application is unarchived, or you think the archived application should register differently in the Contrast application, there may simply be a name conflict. Try running with CONTRAST__APPLICATION__NAME=<name>
to specify a unique name, which will resolve the conflict.