Issue
After configuring AD/LDAP authentication, you receive a 'User locked' message or are unable to login to the Contrast UI for any reason.
Cause
It's possible something went amiss during the configuration of AD/LDAP authentication. Alternatively, if logins were working previously with AD/LDAP we may not be able to reach your AD or LDAP server.
Resolution
In order to access the UI to investigate further, it's possible to manually switch back to local database authentication with these steps:
For Teamserver version 3.9.6 and greater:
Default SuperAdmin users can log in to the Contrast UI while AD or LDAP authentication is configured.
If for any reason you can still not log in, you can manually switch the authentication mode via a change to the Contrast database as follows:
1. From the /Contrast folder run the following and enter the password when prompted:
sudo mysql/bin/mysql -u contrast -h 127.0.0.1 -P 13306 -p contrast
2. Switch to the contrast database:
use contrast;
update teamserver_preferences set property_value = "db" where property_name = "authentication.mode";
For further investigation into the cause of the authentication issues, please open a Support Ticket with your contrast.log from $CONTRAST_HOME/data/logs/contrast.log attached.