No libraries reported in Contrast UI

  • Updated

Issue

Your application has started successfully with the Contrast Java agent. However, the Application and the Server entry in the Contrast UI is reporting no libraries discovered.

Cause

One of the first things the agent does on startup is to perform an inventory of the application which includes discovery of the libraries used by the application.  With supported frameworks, this inventory step should occur regardless of whether the application has seen traffic yet, however in some scenarios it may be necessary to exercise the application before library discovery can occur - or it could be the case that the libraries are located in a non-standard location. 

Resolution

Unsupported Frameworks

In the case of a framework that is not fully supported, please navigate to any URL in your application, using a browser or cURL (or similar utility).

This approach will likely only succeed for applications hosted on servlet-based web servers.

Libraries in a Non-Standard Location

If the libraries are located in a shared folder, the following property can be used to point to them:

-Dcontrast.inventory.library_dirs

(You can list multiple locations using this configuration option by delimiting them with a colon (:) on Linux or a semicolon (;) on Windows).

If the above approaches still yield no results, please contact customer support to open a ticket for further assistance.

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