My application doesn't appear in the Contrast UI

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Issue

The Contrast agent has been deployed and your application is up and running. However it hasn't appeared in the Contrast UI's Application list.

Cause

There are a number of reasons that your application may not be appearing in the Contrast UI. To narrow the issue down, the first thing to check is whether the server the application is running on is present in the Contrast UI's Server list.

If the Server entry exists:

[1] It's possible the application hasn't been used yet.

[2] Alternatively, the application may be running on an unsupported container.

If the Server entry doesn't exist:

[3] If you see neither the Application or Server entries in the Contrast UI or, if other members of the team are able to see the application but not you, it's possible that you're encountering a permissions issue.

[4] It's possible the Application, or an Application with the same name and context path, was archived. If the agent starts up and reports in for an App which has been archived, it receives a response from the Contrast UI to tell it that the App is archived and so not to report anything further.

[5] If permissions are correct and the Application has not been archived, the most likely cause is connectivity issues between the agent and the Contrast UI.

Resolution

[1] Please hit any URL from your application. This can be via a browser or simply with CURL or similar tool. Once the site is visited for the first time, Contrast spends a few seconds analyzing it - even big applications should take less than a minute. You may notice a pause when you first access your application as this analysis is taking place.

[2] Please check our Supported Technologies for details of our supported containers and frameworks.

[3] Your access to applications in the Contrast UI is determined by the Application Access Groups you belong to. An Admin user can assign users to relevant Application Access groups. This can be done through Organization Settings -> Users and opening the relevant user. If necessary, you can create a new Application Access group through Organization Settings -> Groups, in order to grant access to specific Applications.

As a developer, you can onboard your application directly into your Access Group by adding the following to your contrast_security.yaml file:

application:
  group: <name of your access group(s)>
Note: The Access Group must have had the "Applications Onboarded to Group" option set for this property to take effect. If an application already exists, using this property will not work and you will need to contact your Contrast Admin.

[4] You can view archived apps by clicking the highlighted text next to the Applications title and selecting Archived. You can then either Unarchive or fully Delete the Application through the icons on the far right of each entry.

[5] Please see the following articles for assistance debugging connectivity issues:

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