Installation/Upgrade of .Net agents resulting in a 0x80070643 Error

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Issue

In rare circumstances, we have seen users encounter an error referencing 0x80070643 when installing, or updating our .Net Agents (both .Net Core, and .Net Framework). 

This can appear in the Installer Wizard as:

Fatal error during installation. (Exception from HRESULT 0x80070643)

 

Or in the log as:

: Error 0x80070643: Failed to install MSI package.
: Error 0x80070643: Failed to execute MSI package.
: Error 0x80070643: Failed to configure per-machine MSI package.
: Managed: Package 'ContrastSetup_64' apply failed with error '-2147023293' (None).
: Applied execute package: ContrastSetup_64, result: 0x80070643, restart: None
: Error 0x80070643: Failed to execute MSI package.

 

Cause

This is caused by a limitation in the underlying Windows Installer technology. It appears to occur in scenarios where;

  • There are a lot of application pools in IIS
  • There are lots of files that need updating are currently in use
  • The environment has limited resources. 

 

Resolution

It has been found that stopping IIS earlier in the install process, can allow more time for the underlying issue to be resolved, and the issue to by bypassed. 

An option has been added to the Installer Wizard that will allow IIS to be stopped earlier in the process, and prevent this issue from occurring in environments where the agent is being newly installed. 

StopIISearly.png

 

In environments where the agent is already installed, you can run the following PowerShell script to stop IIS earlier in the update process:

New-ItemProperty -Path "HKLM:\Software\Contrast Security, Inc.\Contrast.NET" -Name "StopIisEarly" -Value "1"
New-ItemProperty -Path "HKLM:\Software\Contrast Security, Inc.\Contrast .NET Core Agent for IIS" -Name "StopIisEarly" -Value "1"

 

This has been found to prevent the installation/upgrade error from occurring. If you believe you are running into this issue, please try enabling the above resolution, and if you continue to encounter issues, open a ticket with our Support Team.

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