Why am I seeing duplicate routes?

  • Updated

 

Cause

You’ll notice a few differences in the routes sent up to teamserver across different versions. These differences will result in an increase in the number of routes and may appear as duplicates. Some examples of what you can see:

 

v4.x.x:

Router.route("/bar")
App.use("/fizz", [Function])
Router.get("/prefix","/foo",[Function])

v5.0.0:

Router.get('/prefix/foo', [Function])
Router.get('bar', [Function])

v5.6.2+:

App.use('/fizz',[Function])
Router.get('/bar',[Function])
Router.get('/prefix/foo', [Function])

 

Resolution

Although version 5.6.2 is when we first pushed out the new changes to route coverage data, we recommend upgrading to versions 5.7.5+  which includes bug fixes we found in earlier versions.

 

There are two things you can do here after upgrading the agent:

  1. If you’re already using session_metadata to separate out info from various runs, you will be able to continue to use this to view your route coverage data.
  2. If you’d like to remove the old and stale routes, you will need to clear out all route data. After doing so, restarting the application will give you a clear base line to start from.

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request