Agent Log Warning 'The queue is currently at capacity'

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Issue

The Contrast agent log shows repeated warnings  

WARN - The queue is currently at capacity. Object ObservedRoute{sessionId='0', verb='GET', url='<URL>', signature='ROUTE_SIGNATURE', (...)

 

Cause

This warning is logged when an agent is running in Assess mode, and the route observation queue is overflowing.


Possible reasons for this are:

  1. TeamServer is telling the agent it is overwhelmed and the agent needs to back-off a bit. While the agent is backing-off, routes will build up in the queue.
    If TeamServer is overwhelmed, the server will return an HTTP status code 429 and the log should indicate that the "Queue is full, dropping'

  2. TeamServer is working fine, but the round-trip time to report routes to TeamServer is not fast enough to keep up with the number of routes the application is processing

 

Resolution

By default, route observation queue holds 3000 observation. This can be increased via the following settings:

Yaml Path: agent.reporting.route_coverage.observations.queue.size
Environment Variable: CONTRAST__AGENT__REPORTING__ROUTE_COVERAGE__OBSERVATIONS__QUEUE__SIZE
System Property: -Dcontrast.agent.reporting.route_coverage.observations.queue.size

 

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